Ruby on Rails for Windows2000(Webアプリ開発環境 for Windows2000)

Ruby on Rails for Windows2000

Apache2 PHP5 phpmyadmin mod_fastcgi mod_ruby eRuby Ruby on Rails MySQL5 MySQL/Ruby)


本文へジャンプ

Ruby on Rails対応

初心者の為のRuby on Rails for Fedora Core 5


必要なソフト(Windows)


Fedora Core 5 VMware Player Apache2.0 MySQL5.0 PHP5 FastCGI


VMware Player
VMware-player-1.0.1-19317.exe
「VMwarePlayerをダウンロード」をクリックして、
下記URLの中央にあるDownload NOW Windows版(.exe)をクリック。
http://www.vmware.com/ja/download/player/


2006年8月30日現在、VMware Player用のFedora Core 5のイメージファイルがダウンロードできる。
Fedora Core 5のイメージファイルの場所

HTTP Download
このページの末尾の
If you definitely, definitely can't use BitTorrent, then use the http download link, it's here. Your download will take a few minutes to begin
という文のhereをクリック。

今回は、このファイルをそのまま使う。他にもいろいろなイメージファイルがあるようなので、試してみるとおもしろいかもしれない。

Virtual AppliancesでVirtual Appliance Directoryを以下のように選択するといろいろ見つかる。

Filter by Appliance Type: All Appliances
Filter by Solution Area: Operating Sysyem
Filter by Target User: Developer/Tester


仮想端末ソフト(Windows側のターミナルでFedora Core 5の標準の文字コードUTF-8とSSH2に対応したものを用意する)
UTF-8 TeraTerm Pro with TTSSH2(Japanese version)<UTF-8対応TeraTerm Pro>
ベクターPCショップでダウンロードする。フリーソフト。ライブラリで検索。



FTPクライアント(FFFTP)
ベクターPCショップでダウンロードする。フリーソフト。ライブラリで検索。



Webブラウザ(IE6は、特殊なことをいていて表示がずれる。IE7では改善されるようだ)
Firefox Setup 1.5.0.5.exe


Fedora Core 5
http://ftp.kddilabs.jp/Linux/packages/fedora/core/5/i386/iso/
にあるFC-5-i386-DVD.isoをダウンロードする。(3Gbyteあるのでめちゃめちゃ時間がかかる)
他のミラーサイトからは、うまくダウンロードできなかた。
書籍や雑誌の付録のCD-ROM/DVD-ROMを使用しても良い。
なるべくお金を掛けたくないので、ダウンロードした。






トップページへ
使用したソフトウェア
参考文献
VMware Workstation 5 for Windows日本語版

Windows上で、LinuxなどのゲストOSを新規インストールして、リブート無しで、WindowsとLinux等の複数のOSを同時実行するソフトウェア。



Fedora Core 5で作るネットワークサーバ構築ガイド

サーバ構築の基本を押さえ、しっかり運用できる基礎が書かれたすぐれもの。インストールDVD-ROM付属



 本、ソフトウェアを買うなら。コンピュータ関連の本を探す  
無料メールYahoo! JAPAN MSN Japan
検索エンジンGoogle goo インフォシーク  
インターネットプロバイダBIGLOBE


Ruby on Railsインストールおまかせ(オプション)、root権限で自由にカスタマイズ



Rubyが使用可能、高セキュリティ・レンタルサーバ


Rubyが使用できる!超低価格・仕様は要確認


Rubyが使用できる!高信頼性レンタルサーバー・仕様は要確認


LaCoocan(ラクーカン)でBuby使用可能!・さらに安い


Rubyが使用できる。超多機能、ほぼなんでもあり。超低価格サーバ、Ruby1.8.1その他仕様は要確認。



スポンサー
募集中
メール送信フォームより、タイトルに「スポンサー契約」、本文に返信用メールアドレスを。